У Google нові вимоги до рівня API на Android

1 хв. читання

21 лютого Google оголосила про нові вимоги до застосунків у 2019. Щоб користувачам було зручно взаємодіяти з Android, Google Play вимагатиме останній рівень API:

  • з серпня 2019 — API 28 (Android 9) і вище для нових застосунків;
  • з листопада — оновлення випущених застосунків до рівня API 28 і вище.

Також цьогоріч китайські великі магазини, зокрема Huawei, OPPO, Vivo, Xiaomi, Baidu, Alibaba і Tencent, вимагатимуть мінімальний рівень API 26 (Android 8.0) або вище.

Понад 95 % шпигунських програм, виявлених за межами Play Store, навмисне зосереджуються на API 22 або нижче, уникаючи runtime-дозволів навіть у разі встановлення на останніх версіях Android. Тому, щоб захистити користувачів від шкідливого програмного забезпечення, служба Google Play Protect попереджатиме про спроби встановити APK з будь-якого джерела, що не орієнтується на недавній рівень API.

Опубліковані раніше програми, які не оновлюються і не змінюються, продовжать завантажуватися з Play Store. У застосунках все ще може бути будь-який minSdkVersion, тож зі створенням програм для старих версій Android нічого не змінилось.

Помітили помилку? Повідомте автору, для цього достатньо виділити текст з помилкою та натиснути Ctrl+Enter
Codeguida 5.2K
Приєднався: 9 місяців тому
Коментарі (0)

    Ще немає коментарів

Щоб залишити коментар необхідно авторизуватися.

Вхід / Реєстрація