Запитати

Не запускаються snap пакети на Ubuntu. snap-confine has elevated permissions...

Вирішено
17 листопада 2020 · 210 ·
1

Під час запуску snap пакету отримую помилку:

snap-confine has elevated permissions and is not confined but should be. 
Refusing to continue to avoid permission escalation attacks

Як це можна виправити?

ubuntu snap linux

Відповіді на питання (1)

17 листопада 2020
0
Обране рішення

Це можна обійти якщо виконати команду:

$ sudo apparmor_parser -r /etc/apparmor.d/*snap-confine*

Це зробить запуск snap-confine "обмеженим" і snap програми будуть запускатися. Якщо помилка виникне знову, цю команду необхідно буде виконати повторно.


Для відповіді на запитання необхідно авторизуватись

Вхід / Реєстрація