Bootstrap не буде підтримувати Internet Explorer

1 хв. читання

UI-фреймворк Bootstrap не буде підтримувати Internet Explorer 10 і 11. Це діятиме з версії 5, яка має вийти наприкінці року. Марк Отто, один з авторів Bootstrap, написав на GitHub, що ті, кому потрібен IE, можуть використовувати Bootstrap 4 і не оновлюватись до наступного релізу.

Фреймворк Bootstrap спочатку розробили для Twitter, але потім код проєкту відкрили й він набув популярності. Зокрема через простоту, гарно прописану документацію та міжбраузерну підтримку (адже Twitter мав працювати у всіх однаково).

У бібліотеці Bootstrap зібрані UI-віджети для HTML, CSS і JavaScript, якими послуговуються розробники сайтів і застосунків. За даними BuiltWith, Bootstrap використовують на 20 мільйонах ресурсів, а в статистиці W3Techs йдеться про 20% усіх сайтів взагалі.

Screenshot-15

Те, що Bootstrap відмовиться від підтримки IE, може стати знаковим рішенням. Адже інші проєкти так не робили — наприклад, jQuery (яка використовується на ¾ усіх сайтів) все ще підтримує IE 9. Однак браузером користується 1-2% аудиторії, а Microsoft більше цікавить розвиток Edge, а не IE, тож розробники, імовірно, почнуть відмовлятись від нього.

Команда WordPress вже розповіла про свій план взаємодії з IE та назвала його «Graceful Degradation». Суть в тому, що підтримку залишать, але частково і лише для основних функцій CMS.

Помітили помилку? Повідомте автору, для цього достатньо виділити текст з помилкою та натиснути Ctrl+Enter
Codeguida 4.7K
Приєднався: 10 місяців тому
Коментарі (0)

    Ще немає коментарів

Щоб залишити коментар необхідно авторизуватися.

Вхід / Реєстрація